Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 09-30-2012, 16:31   #1
OctoberRust
Anti-Federalist
 
Join Date: Jun 2011
Location: Texas
Posts: 5,642
I'm such a noob. Input welcome though.....

Ok, so I decided to try out a spectre CQB sling on one of my mossberg 500s. So I put it on, and go shooting clays today. Out of 50 I get 2 light strikes on the shells, and thought at first maybe they were hard primers, etc. so once we're finished, I was still thinking wth was going on, since this particular mossberg has seen 500+ shells with no issues at all.

After discussing it a little further, I bring out my other mossberg 500 with no sling, pop in the 2 dented primer'd shells and this mossberg fires them no problem at all. So I was thinking, that's strange. After thinking what may be causing this, I remember I installed the sling between the barrel lug and the tubular magazine, possibly creating more of a space between the two than there should be, leading to some light strikes.


Does this sound right? Also seems like the barrel came a little loose on the one with the spectre sling (because I believe I installed this incorrectly). Basically, I know I'm an idiot, and I should have looked further into how it's really supposed to be installed on the gun.
OctoberRust is offline   Reply With Quote
Old 09-30-2012, 17:32   #2
Buffering
The Cooler
 
Buffering's Avatar
 
Join Date: Aug 2005
Location: Rocking the Casbah
Posts: 1,774


You know, I just can't add any more than that.
__________________
"Of every 100 men that go to battle 70 should not even be there, 20 are nothing but targets, 9 are true soldiers, and we are lucky to have them for they the battle make but ONE, one is a warrior, and HE will bring the others home." Hericlitus
Buffering is offline   Reply With Quote
Old 09-30-2012, 18:13   #3
OctoberRust
Anti-Federalist
 
Join Date: Jun 2011
Location: Texas
Posts: 5,642
Quote:
Originally Posted by Buffering View Post
You know, I just can't add any more than that.



Does that sound about right, why I was probably getting those two FTF?
OctoberRust is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 02:14.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 728
144 Members
584 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31