GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.
Reply
 
Thread Tools Display Modes
Old 10-23-2012, 03:10   #1
theflatlander
Member
 
Join Date: Apr 2012
Posts: 70
AA conversion kit not locking up correctly.

I have had my AA kit for my g23 gen4 for about a week. The kit I bought didn't have the mag in it unfortunately so I just bought 3 more and received them today.

I was just tinkering with the kit when I got tonight and I noticed that it didn't seem to be locking up correctly. The mechanism you use to switch out the slides (not sure what its called off hand) will not lock up with the conversion slide unless I give it some help. The thing i noticed is the slide isn't locked up completely right compared to the frame of the gun.

I would say it its about a 1/8 or a 1/16th of a inch off comparing to where it should be sitting normally and where it is sitting. Its enough to notice visually and by looking at the back plate of the slide its off by about the thickness of the plastic back plate. Everything still cycles fine, ejected the round fine and cycle the next one in fine. I used to some dry fire .22 rounds and the firing mechanism and everything mechanically seems to check out.

Just bothers me that the slide doesn't fit perfect to the frame and I am wondering if I should quit worrying about and shoot? Is their anything I can do to fix this myself? I know the kit should be under warranty but I dont have a actual receipt and I cant prove that I bought it new. Could any gunsmith fix the problem or can I?

any information appreciated.
theflatlander is offline   Reply With Quote
Old 10-23-2012, 03:32   #2
Arc Angel
Deus Vult!
 
Arc Angel's Avatar
 
Join Date: Sep 2003
Location: Penn's Woods
Posts: 10,956
Blog Entries: 55
Do you have the slide lock (The mechanism you use to switch out the slides.) in backwards?

http://imageshack.us/a/img27/8281/go...kschematic.jpg

Load two or three rounds, make sure the slide is closed, and single-fire the pistol. Does the slide fully RTB and lock up each time? If not, you need to visit a gunsmith.

Last edited by Arc Angel; 10-23-2012 at 03:49..
Arc Angel is offline   Reply With Quote
Old 10-23-2012, 05:54   #3
stolenphot0
RTF2 Addict
 
stolenphot0's Avatar
 
Join Date: Jan 2012
Location: Kettering, OH
Posts: 4,965
After installing the slide, and the gun is empty, press the muzzle. That should lock it in place. I this same problem with my kit on my gen2 19. I sent an email to AA and that is what fixed it. They even offered to machine the lugs down if it wasn't fitting.
__________________
--
Want to help my wife win a new mobility van?
Click here to vote


Last edited by stolenphot0; 10-23-2012 at 05:55..
stolenphot0 is offline   Reply With Quote
Old 10-23-2012, 13:11   #4
theflatlander
Member
 
Join Date: Apr 2012
Posts: 70
yes the mechanism is in correctly. You don't need to take to mechanism out to switch the slides. It is my intention to shoot the firearm like this until I know its not going to blow up in my face before hand. I cycled through about 10 rounds of ammo last night, letting the slide slam home like I would. Everything mechanically seems fine one the slide lock is engaged.

trigger worked fine, cycled the round out fine and cycle the next one in fine. The only way I can explain it besides the slide isn't lined up completely on the frame when the slide is fully locked is when the slide is at where it should line up on the frame the slide mechanism is only engaging half way and I cannot manually force the mechanism to engage the conversion slide in the position where it should be.

Quote:
Originally Posted by Arc Angel View Post
Do you have the slide lock (The mechanism you use to switch out the slides.) in backwards?

http://imageshack.us/a/img27/8281/go...kschematic.jpg

Load two or three rounds, make sure the slide is closed, and single-fire the pistol. Does the slide fully RTB and lock up each time? If not, you need to visit a gunsmith.
theflatlander is offline   Reply With Quote
Old 10-23-2012, 13:13   #5
theflatlander
Member
 
Join Date: Apr 2012
Posts: 70
Quote:
Originally Posted by stolenphot0 View Post
After installing the slide, and the gun is empty, press the muzzle. That should lock it in place. I this same problem with my kit on my gen2 19. I sent an email to AA and that is what fixed it. They even offered to machine the lugs down if it wasn't fitting.
thanks stolen. Im going to try that right now/
theflatlander is offline   Reply With Quote
Old 10-23-2012, 13:56   #6
theflatlander
Member
 
Join Date: Apr 2012
Posts: 70
I did as you said stolen and thats what I am explaining happens when I get it to lock up. I dont know if this will cause extra stress on the slide, or if it will effect the dependability of the slide.

this pic is about the best way to explain what I mean on how it isnt lining up properly. This is the recoil spring sticking out when I have the slide locked in

General Glocking

This what I mean by the slide lock mechanism not fully engaged when the slide is sitting where it should be.

General Glocking
theflatlander is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 23:31.



Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 974
266 Members
708 Guests

Most users ever online: 2,244
Nov 11, 2013 at 11:42