GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 01-29-2013, 21:54   #1
Socom Elite
Registered User
 
Join Date: Feb 2010
Posts: 16
G23 with TLR-1 issues

I know there are already threads on this, but has anyone found a solution? I have a gen 3 and my mags have a 2 next to the Glock logo on the back and a 9 on the follower so I think they are the new ones, but I am having a lot of failure to feed malfunctions.

Usually in these threads I see all these posts about how their gun works. I want to hear from the people that had problems and what if any was the solution.

I had the screw tight i guess, but only hand tight. When I got home after the range today and researched the issue I loosened it a turn so its loose, but won't come off. Ill take it to the range again Friday and put some more ammo through it and see how it does.

I really want to be able to run this light on my gun, but I can't sacrifice reliability for it.

Last edited by Socom Elite; 02-02-2013 at 17:30..
Socom Elite is offline   Reply With Quote
Old 02-02-2013, 17:29   #2
Socom Elite
Registered User
 
Join Date: Feb 2010
Posts: 16
Anyone?
Socom Elite is offline   Reply With Quote
Old 02-02-2013, 17:43   #3
bennie1986
Senior Member
 
bennie1986's Avatar
 
Join Date: Dec 2012
Posts: 152
Does the slide fail to fully engage the next round or does the round get jammed on something?
bennie1986 is offline   Reply With Quote
Old 02-02-2013, 17:47   #4
bennie1986
Senior Member
 
bennie1986's Avatar
 
Join Date: Dec 2012
Posts: 152
Also what kind of ammo are you using and are there any mods to the gun and specifically the guide rod spring.
bennie1986 is offline   Reply With Quote
Old 02-02-2013, 18:29   #5
Socom Elite
Registered User
 
Join Date: Feb 2010
Posts: 16
Quote:
Originally Posted by bennie1986 View Post
Also what kind of ammo are you using and are there any mods to the gun and specifically the guide rod spring.
The gun is completely stock. I used. Blazer brass, Tula, and federal.i think the majority of failure to feeds were from blazer and tula. Yes I know they're cheap ammo, but I've never had a problem with it in any other firearm. I wanted to go shoot yesterday but couldn't make it out. Maybe next weekend.

The failures were failure to feed btw.

I have read plenty of other stories about this happening to others. Hopefully someone found a solution.

I already emailed Glock and are awaiting their response
Socom Elite is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 14:50.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,008
286 Members
722 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31